Terminix nouvelle version

Pour ceux qui ne le connaissent pas encore, Terminix, dont la version 1.1.0 beta vient de sortir, est un terminal du même genre que Terminator, ce qu’on appelle un « tiling terminal ».

Si nous traduisons littéralement ce terme, ça donnerait quelque chose comme « terminal à tuiles« . Mais il faut plutôt voir entendre ici « terminal à fenêtres flottantes », qui se positionnent automatiquement dès qu’on subdivise le terminal en plusieurs parties (comme les gestionnaires de fenêtres de type i3) comme vous pouvez voir ci-dessous, mais peuvent aussi être réarrangées en drag n’ drop.

Screenshot from 2016-07-18 20-23-01

Sur la page Github du projet, il est indiqué que la version Ubuntu (et donc Debian, Kali, et toute la famille deb) n’est pas encore disponible. Nous allons donc procéder autrement pour y parvenir. Avant de l’installer, vous devez vous assurer wget unzip libglib2.0-bin sont installés. En cas de doute ou s’ils ne sont pas encore sut votre machine, lancez cette commande :

sudo apt-get install wget unzip libglib2.0-bin

Maintenant, pour installer Terminix, ouvrez un terminal et allez dans le dossier tmp. Récupérez ensuite le zip sur Github :

cd /tmp

wget https://github.com/gnunn1/terminix/releases/download/1.1.1/terminix.zip

On extrait le contenu du zip :

sudo unzip terminix.zip -d /

Et pour finir on compile :

sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

Maintenant tapez terminix dans votre terminal ou cliquez sur l’icone dans votre menu pour le lancer. Je pense maintenant qu’il n’y a pas besoin d’explication pour la suite. L’utilisation est très simple et très intuitive : en haut à gauche, 2 boutons pour diviser horizontalement et verticalement que vous pourrez ensuite déplacer à la souris, ainsi qu’un gros bouton pour créer des terminaux virtuels.

IMPORTANT : Si vous utilisez l’environnement Gnome, tout devrait rouler du premier coup. Par contre, pour certains environnement (Mate par exemple), vous pourrez parfois obtenir ce type d’erreur de ce type :

Screenshot

Il suffit d’installer la dernière version de libvte (Vérifiez la version en cours avec un apt-cache search libvte)

sudo apt-get install libvte-2.91-0

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *